/[MITgcm]/MITgcm/pkg/ecco/cost_averagesgeneric.F
ViewVC logotype

Log of /MITgcm/pkg/ecco/cost_averagesgeneric.F

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Links to HEAD: (view) (download) (annotate)
Sticky Tag:

Revision 1.10 - (view) (download) (annotate) - [select for diffs]
Mon Mar 23 21:10:04 2015 UTC (9 years, 1 month ago) by gforget
Branch: MAIN
CVS Tags: HEAD, checkpoint65k, checkpoint65l, checkpoint65m, checkpoint65n, checkpoint65o, checkpoint65p, checkpoint65q, checkpoint65r, checkpoint65s, checkpoint65t, checkpoint65u, checkpoint65v, checkpoint65w, checkpoint65x, checkpoint65y, checkpoint65z, checkpoint66a, checkpoint66b, checkpoint66c, checkpoint66d, checkpoint66e, checkpoint66f, checkpoint66g, checkpoint66h, checkpoint66i, checkpoint66j, checkpoint66k, checkpoint66l, checkpoint66m, checkpoint66n, checkpoint66o
Changes since 1.9: +18 -1 lines
Diff to previous 1.9
- use eccoiter in place of optimcycle.
- if autodiff is not compiled then use READ_REC_XY_RL/READ_REC_XYZ_RL instead of active read/write


Revision 1.9 - (view) (download) (annotate) - [select for diffs]
Wed Oct 22 13:28:27 2014 UTC (9 years, 6 months ago) by gforget
Branch: MAIN
CVS Tags: checkpoint65g, checkpoint65h, checkpoint65i, checkpoint65j
Changes since 1.8: +27 -3 lines
Diff to previous 1.8
o pkg/ecco : add capability to penalize full series of time steps,
  (rather than daily or month;y) for use in short verification experiments.
  - cost_gencost_assignperiod.F : add myiter as argument.
  - cost_averagesfields.F : add ECCO_CTRL_DEPRECATED brackets,
    and myiter argument to cost_gencost_assignperiod.F.
  - cost_averagesgeneric.F : if (startofloc .and. endofloc)
    then write current time step field.
o pkg/ecco/cost_generic.F : add smoother as post-processing capability.


Revision 1.8 - (view) (download) (annotate) - [select for diffs]
Mon Sep 29 16:47:49 2014 UTC (9 years, 7 months ago) by gforget
Branch: MAIN
CVS Tags: checkpoint65f
Changes since 1.7: +37 -10 lines
Diff to previous 1.7
- remove includes from pkg/ctrl, add missing CCP switches,
  remove unused variable, replace optimiter with eccoiter :
  cost_averagesgeneric.F, cost_gencost*.F,
  cost_generic.F, ecco_check.F, ecco_phys.F
- include ecco.h rather than ecco.h : ecco_cost_driver.F,
  ecco_phys.F, cost_averagesgeneric.F, cost_gencost*.F,
- rename xx_genbar_dummy as gencost_dummy : cost_averagesfields.F,
  cost_averagesinit.F, cost_gencost_*.F, ecco_cost_init_barfiles.F


- cost_bp.F : modify calls to cost_bp_read (added arguments)
- cost_bp_read.F added arguments (localobsfile, localstartdate,
     localobs, localmask) replacing use of common blocs
- cost_generic.F : add ALLOW_OLD_ESTIM_CODES bracket
- ecco_check.F :
    use gencost_startdate rather than modelstartdate, rename
    using_topex as using_tpj, add ALLOW_OLD_ESTIM_CODES brackets
- cost_gencost_all.F : remove un-necessary CPP brackets of
    cost_gencost_*v4 calls, add cost_gencost_bpv4 call,
    use gencost_startdate rather than modelstartdate
- cost_averagesgeneric.F : added DEBUG code
- ecco_cost_final.F : added ifdef ALLOW_ECCO
- ecco_cost_init_fixed.F : copy optimcycle to eccoiter
  when ALLOW_CTRL, set eccoiter to 0 otherwise;
  revise gencost conditionality
- ecco_cost_summary.F : add ALLOW_OLD_ESTIM_CODES brackets,
  rename using_topex as using_tpj
- ecco_init_varia.F : initialize RHOsumGlob_0, VOLsumGlob_0
- ecco_phys.F : compute etanFull
- ecco_readparms.F : rename using_topex as using_tpj, add
  bpv4-grace to gencost list, initialize added parameters
- ecco_summary.F : include SIZE.h needed for augmented ecco.h


Revision 1.7 - (view) (download) (annotate) - [select for diffs]
Fri Aug 10 19:45:25 2012 UTC (11 years, 8 months ago) by jmc
Branch: MAIN
CVS Tags: checkpoint63r, checkpoint63s, checkpoint64, checkpoint64a, checkpoint64b, checkpoint64c, checkpoint64d, checkpoint64e, checkpoint64f, checkpoint64g, checkpoint64h, checkpoint64i, checkpoint64j, checkpoint64k, checkpoint64l, checkpoint64m, checkpoint64n, checkpoint64o, checkpoint64p, checkpoint64q, checkpoint64r, checkpoint64s, checkpoint64t, checkpoint64u, checkpoint64v, checkpoint64w, checkpoint64x, checkpoint64y, checkpoint64z, checkpoint65, checkpoint65a, checkpoint65b, checkpoint65c, checkpoint65d, checkpoint65e
Changes since 1.6: +2 -2 lines
Diff to previous 1.6
include ECCO_OPTIONS.h instead of COST_CPPOPTIONS.h


Revision 1.6 - (view) (download) (annotate) - [select for diffs]
Fri Aug 10 14:34:41 2012 UTC (11 years, 8 months ago) by gforget
Branch: MAIN
Changes since 1.5: +5 -5 lines
Diff to previous 1.5
- ecco_cost_final.F : add fc definition when pkg/cost is omitted,
  omit global_sum of fc when pkg/cost is included (see joint modif).
- ecco_cost.h : define tbar, sbar, ubar, vbar accordingly if ALLOW_COST_TRANSPORT.
- add CPP brackets around pkg/cost and pkg/ctrl includes of "CTRL_SIZE.h"
  "ctrl.h" "ctrl_dummy.h" "optim.h" / "cost.h" accordingly.
- ALLOW_COST_ATLANTIC_HEAT vs ALLOW_COST_ATLANTIC :
  attempt to sort out ALLOW_COST_ATLANTIC (in ecco) vs
  ALLOW_COST_ATLANTIC_HEAT (in cost) that both use objf_atl (from cost).
- ALLOW_COST_ATLANTIC ifdef ALLOW_ECCO_EVOLUTION : add calls
  to cost_atlantic (that also does the associated time averaging)
  in cost_averagesfields.F and ecco_cost_driver.F, along with
  the relevant ecco_ad_check_lev*_dir.h stores.


Revision 1.5 - (view) (download) (annotate) - [select for diffs]
Tue Jul 31 16:07:32 2012 UTC (11 years, 9 months ago) by heimbach
Branch: MAIN
Changes since 1.4: +3 -1 lines
Diff to previous 1.4
Attempt at adding CTRL_SIZE.h


Revision 1.4 - (view) (download) (annotate) - [select for diffs]
Sat Mar 14 11:53:41 2009 UTC (15 years, 1 month ago) by heimbach
Branch: MAIN
CVS Tags: checkpoint61j, checkpoint61k, checkpoint61l, checkpoint61m, checkpoint61n, checkpoint61o, checkpoint61p, checkpoint61q, checkpoint61r, checkpoint61s, checkpoint61t, checkpoint61u, checkpoint61v, checkpoint61w, checkpoint61x, checkpoint61y, checkpoint61z, checkpoint62, checkpoint62a, checkpoint62b, checkpoint62c, checkpoint62d, checkpoint62e, checkpoint62f, checkpoint62g, checkpoint62h, checkpoint62i, checkpoint62j, checkpoint62k, checkpoint62l, checkpoint62m, checkpoint62n, checkpoint62o, checkpoint62p, checkpoint62q, checkpoint62r, checkpoint62s, checkpoint62t, checkpoint62u, checkpoint62v, checkpoint62w, checkpoint62x, checkpoint62y, checkpoint62z, checkpoint63, checkpoint63a, checkpoint63b, checkpoint63c, checkpoint63d, checkpoint63e, checkpoint63f, checkpoint63g, checkpoint63h, checkpoint63i, checkpoint63j, checkpoint63k, checkpoint63l, checkpoint63m, checkpoint63n, checkpoint63o, checkpoint63p, checkpoint63q
Changes since 1.3: +2 -2 lines
Diff to previous 1.3
o A final fix in cost_ssh_new(!)
o Move ecco_check to earlier instance
o Increase maxNumDays to 17yr
o A few debug calls


Revision 1.3 - (view) (download) (annotate) - [select for diffs]
Tue Oct 9 00:02:50 2007 UTC (16 years, 6 months ago) by jmc
Branch: MAIN
CVS Tags: checkpoint59i, checkpoint59j, checkpoint59k, checkpoint59l, checkpoint59m, checkpoint59n, checkpoint59o, checkpoint59p, checkpoint59q, checkpoint59r, checkpoint60, checkpoint61, checkpoint61a, checkpoint61b, checkpoint61c, checkpoint61d, checkpoint61e, checkpoint61f, checkpoint61g, checkpoint61h, checkpoint61i
Changes since 1.2: +7 -6 lines
Diff to previous 1.2
add missing cvs $Header:$ or $Name:$


Revision 1.2 - (view) (download) (annotate) - [select for diffs]
Thu Sep 1 23:24:45 2005 UTC (18 years, 8 months ago) by heimbach
Branch: MAIN
CVS Tags: checkpint57u_post, checkpoint57r_post, checkpoint57s_post, checkpoint57t_post, checkpoint57v_post, checkpoint57w_post, checkpoint57x_post, checkpoint57y_post, checkpoint57y_pre, checkpoint57z_post, checkpoint58, checkpoint58a_post, checkpoint58b_post, checkpoint58c_post, checkpoint58d_post, checkpoint58e_post, checkpoint58f_post, checkpoint58g_post, checkpoint58h_post, checkpoint58i_post, checkpoint58j_post, checkpoint58k_post, checkpoint58l_post, checkpoint58m_post, checkpoint58n_post, checkpoint58o_post, checkpoint58p_post, checkpoint58q_post, checkpoint58r_post, checkpoint58s_post, checkpoint58t_post, checkpoint58u_post, checkpoint58v_post, checkpoint58w_post, checkpoint58x_post, checkpoint58y_post, checkpoint59, checkpoint59a, checkpoint59b, checkpoint59c, checkpoint59d, checkpoint59e, checkpoint59f, checkpoint59g, checkpoint59h
Changes since 1.1: +1 -2 lines
Diff to previous 1.1
Remove obsolete header.


Revision 1.1 - (view) (download) (annotate) - [select for diffs]
Thu Sep 1 05:32:56 2005 UTC (18 years, 8 months ago) by heimbach
Branch: MAIN
o Adding cost term for seaice obs (daily SMR vs. AREA)
  new seaice_cost init/weight/final routines
o Modularized cost_averages routines (new cost_averagesgeneric.F)


This form allows you to request diffs between any two revisions of this file. For each of the two "sides" of the diff, select a symbolic revision name using the selection box, or choose 'Use Text Field' and enter a numeric revision.

  Diffs between and
  Type of Diff should be a

Sort log by:

  ViewVC Help
Powered by ViewVC 1.1.22